Draft notes regarding compiling the Kannel source RPM on a RAQ550:

Decided to use the Fedora Core 3 SRPM:

$ wget http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/3/kannel/kannel-1.4.0-3.1.fc3.fr.src.rpm
$ rpm --rebuild --nodeps kannel-1.4.0-3.1.fc3.fr.src.rpm

...which failed with a warning regarding an obsolete libxml2. That seemed easy enough to fix, picking up the Core 4 SRPM:

$ wget http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/SRPMS/libxml2-2.6.19-1.src.rpm
$ rpm --rebuild libxml2-2.6.19-1.src.rpm

...which in turn fails due to the totally obsolete libtool, which in turn needs autoconf and automake, which in turn can't be installed from current RPMs.

$ wget http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/SRPMS/libtool-1.5.16.multilib2-1.src.rpm
$ wget http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/SRPMS/autoconf-2.59-5.src.rpm
$ rpm --rebuild libtool-1.5.16.multilib2-1.src.rpm